Assertion "Problems getting GL version using glGetString"

Problems building or running the engine, queries about how to use features etc.

Assertion "Problems getting GL version using glGetString"

Postby nikki » Mon Jan 05, 2009 1:34 pm

I built Ogre and the Samples on Arch Linux on my laptop, and when I try to run a sample, it says:-

Code: Select all
OgreGLSupport.cpp:57: virtual void Ogre::GLSupport::initialiseExtensions: Assertion `pcVer && "Problems getting GL version string using glGetString"' failed

The log goes until the creation of the GLX subsystem.

I'd installed, built and run Ogre-using applications both on Windows and on Ubuntu on this laptop, so it should run fine with this hardware. I think its a driver issue, but I have 'xf86-video-intel' installed. 'lspci | grep VGA' gives:-

Code: Select all
Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

I did search on the forums, but there isn't much about this. Where ever someone mentions a problem, it was because he didn't have the required hardware or something.

Any ideas? :D
User avatar
nikki
Old One
 
Posts: 2730
Kudos: 13
Joined: 17 Sep 2005
Location: Princeton, New Jersey, USA

Re: Assertion "Problems getting GL version using glGetString"

Postby nikki » Mon Jan 05, 2009 1:44 pm

Oh wait, 'glxinfo' mentions 'Mesa software renderer'. :?
User avatar
nikki
Old One
 
Posts: 2730
Kudos: 13
Joined: 17 Sep 2005
Location: Princeton, New Jersey, USA

Re: Assertion "Problems getting GL version using glGetString"

Postby nikki » Mon Jan 05, 2009 3:21 pm

Well, to check whether glGetString() works, I took the program from the NeHe tutorial and modified it to spit out glGetString results, and it says "Vendor: Mesa Project, Renderer: Software Rasterizer, Version: 2.1 Mesa 7.2". Is this good, or not?

I'm confused. :?
User avatar
nikki
Old One
 
Posts: 2730
Kudos: 13
Joined: 17 Sep 2005
Location: Princeton, New Jersey, USA

Re: Assertion "Problems getting GL version using glGetString"

Postby nikki » Sun Jan 11, 2009 1:32 pm

Finally got around to fixing it! :D

I had to just put this in the xorg.conf. Seems I was missing DRI.

Code: Select all
Section "DRI"
    mode 0666
EndSection
User avatar
nikki
Old One
 
Posts: 2730
Kudos: 13
Joined: 17 Sep 2005
Location: Princeton, New Jersey, USA

Re: Assertion "Problems getting GL version using glGetString"

Postby surgio » Mon Mar 09, 2009 11:26 am

i have the same problem.

compiled ogre from source successfully but attempting to run the samples produces this error.

i've tried the fix suggested. is there something else to the fix than just add those 3 lines to xorg.conf?

i'm trying to get ogre to run on ubuntu as a guest os in vmware.
surgio
Gnoblar
 
Posts: 3
Kudos: 0
Joined: 09 Mar 2009

Re: Assertion "Problems getting GL version using glGetString"

Postby nikki » Mon Mar 09, 2009 1:27 pm

Seems Ubuntu isn't able to 'catch' your graphics card from VMWare. Are you sure you have the correct drivers in Ubuntu? You'll have to install one of the 'nvidia-glx-*' packages I believe.
User avatar
nikki
Old One
 
Posts: 2730
Kudos: 13
Joined: 17 Sep 2005
Location: Princeton, New Jersey, USA

Re: Assertion "Problems getting GL version using glGetString"

Postby surgio » Tue Mar 10, 2009 4:34 pm

i think i have. glxgears runs fine. is this a sufficient enough check to make sure that the nvidia driver is installed?
surgio
Gnoblar
 
Posts: 3
Kudos: 0
Joined: 09 Mar 2009

Re: Assertion "Problems getting GL version using glGetString"

Postby nikki » Tue Mar 10, 2009 11:09 pm

surgio wrote:i think i have. glxgears runs fine. is this a sufficient enough check to make sure that the nvidia driver is installed?

No, glxgears can run with mesa too, which is a software renderer. Ogre requires hardware support.
User avatar
nikki
Old One
 
Posts: 2730
Kudos: 13
Joined: 17 Sep 2005
Location: Princeton, New Jersey, USA

Re: Assertion "Problems getting GL version using glGetString"

Postby surgio » Wed Mar 11, 2009 6:02 pm

ahh gotcha. been looking around, my answer is vmgl which i read is hard to get working. thanks anyway :)
surgio
Gnoblar
 
Posts: 3
Kudos: 0
Joined: 09 Mar 2009

Re: Assertion "Problems getting GL version using glGetString

Postby Killix » Thu Jan 27, 2011 5:34 pm

I have the same problem when compiling and runing Ogre3D 1.7.2 on my VMWare with Ubuntu 9.10.
=> It is come when updating the Ubuntu system and VMWareTools.

The first solution in xorg.conf did not worked.

I solved it by installing the package "nvidia-glx-180". Here is the installation log :

Code: Select all
Commit Log for Thu Jan 27 17:05:29 2011


Removed the following packages:
libgl1-mesa-dev
mesa-common-dev

Installed the following packages:
dkms (2.0.21.1-0ubuntu3)
fakeroot (1.12.1ubuntu1)
libdrm-nouveau1 (2.4.5-0ubuntu4)
nouveau-kernel-source (0.0.11+git20090404-0ubuntu1)
nvidia-180-kernel-source (180.44-0ubuntu1)
nvidia-180-libvdpau (180.44-0ubuntu1)
nvidia-glx-180 (180.44-0ubuntu1)
nvidia-glx-180-dev (180.44-0ubuntu1)
nvidia-settings (180.25-0ubuntu1)
patch (2.5.9-5)




Hope it may help

Nktug

(One of the fan of Ogre3D engine)
http://the-cyber-cube.net
User avatar
Killix
Gnoblar
 
Posts: 6
Kudos: 1
Joined: 31 Mar 2007


Return to Help

Who is online

Users browsing this forum: Baidu [Spider] and 4 guests