Text no display with SdkTrays

Problems building or running the engine, queries about how to use features etc.

Text no display with SdkTrays

Postby Bpopey » Thu Jul 29, 2010 10:59 am

I have a little trouble. I tried the example archive SdkTraySample.zip
it works very well with Ogre v1.7.0, but when I compile it and execute it
with the version of Ogre v1.7.1, I have not the text display.

Image

What changes between these two versions can get this bug?
Or whatadaptation code does it make?

Thank you for your help ;)
Bpopey
Gnoblar
 
Posts: 10
Kudos: 0
Joined: 29 Jul 2010

Re: Text no display with SdkTrays

Postby dyndnsboy » Thu Jul 29, 2010 11:35 am

I had the same problem when putting on left position.

When i changed to right, it worked.

Also when i use another police, image based, not ttf it works at any position.
dyndnsboy
Gnoblar
 
Posts: 4
Kudos: 0
Joined: 21 Jul 2010

Re: Text no display with SdkTrays

Postby Bpopey » Thu Jul 29, 2010 12:00 pm

dyndnsboy wrote:When i changed to right, it worked.

it's the same thing for me.

dyndnsboy wrote:Also when i use another police, image based, not ttf it works at any position.

is an interesting information :)

but this difference between the latest version of Ogre is strange .. :?
Bpopey
Gnoblar
 
Posts: 10
Kudos: 0
Joined: 29 Jul 2010

Re: Text no display with SdkTrays

Postby Bpopey » Tue Aug 31, 2010 8:58 pm

up

some users have the same worries?

I still can not put my finger on the detail that does not work ...

Is there than we have encountered this problem with version 1.7.1 and SDKTray Ogre ?

:mrgreen:
Bpopey
Gnoblar
 
Posts: 10
Kudos: 0
Joined: 29 Jul 2010

Re: Text no display with SdkTrays

Postby ta_gopinath » Fri Sep 03, 2010 12:34 pm

hello

before creating the buttons, add this line

Ogre::FontManager::getSingleton().getByName("SdkTrays/Caption")->load();

issue is related with the fonts.

Thanks & Regards,
A. Gopinath.
ta_gopinath
Gnoblar
 
Posts: 15
Kudos: 2
Joined: 07 Jul 2010

Re: Text no display with SdkTrays

Postby Bpopey » Fri Sep 03, 2010 3:54 pm

it was so simple. :shock:

Thank you very much, really :D
you saved my life (almost)
Bpopey
Gnoblar
 
Posts: 10
Kudos: 0
Joined: 29 Jul 2010

Re: Text no display with SdkTrays

Postby omniter » Sat Sep 04, 2010 5:29 am

This is a bug in Ogre 1.7, not SdkTrays, and has been reported many times. Something about OverlayElements not updating their widths at the right time (but only for pixel metric). So be wary when using non-SdkTrays interfaces as well.
User avatar
omniter
OGRE Contributor
OGRE Contributor
 
Posts: 424
Kudos: 44
Joined: 19 Mar 2009
Location: Canada

Re: Text no display with SdkTrays

Postby orc lord » Sun Sep 05, 2010 4:41 pm

I solved this problem by calling mTrayMgr->adjustTrays(); once after rendering had started. for example in frameRenderingQueued;
orc lord
Gnoblar
 
Posts: 2
Kudos: 0
Joined: 05 Sep 2010
Location: Germany

Re: Text no display with SdkTrays

Postby omniter » Sun Sep 05, 2010 5:04 pm

That is a good temporary solution until the bug gets fixed, since adjustTrays sets the dimensions and positions of all the OverlayElements. Any operation that will cause the OverlayElement's geom positions to be refreshed will fix this problem.
User avatar
omniter
OGRE Contributor
OGRE Contributor
 
Posts: 424
Kudos: 44
Joined: 19 Mar 2009
Location: Canada

Re: Text no display with SdkTrays

Postby dave2041 » Tue Apr 19, 2011 11:56 am

As a small update, should you have a slider or Select Menu, and the value select isn't showing use this line:

Code: Select all
Ogre::FontManager::getSingleton().getByName("SdkTrays/Value")->load();


In a similar manor to the previous fix for the button captions.
dave2041
Halfling
 
Posts: 71
Kudos: 0
Joined: 24 Apr 2009

Re: Text no display with SdkTrays

Postby conx » Fri Jul 18, 2014 1:07 am

I'm digging it out just to notice that i have the same issue with Ogre 1.8.1 !
Thanks,Rafal
conx
Kobold
 
Posts: 32
Kudos: 0
Joined: 10 May 2012


Return to Help

Who is online

Users browsing this forum: Yahoo [Bot] and 8 guests