GLU not found building GL RenderSystem

Minor issues with the Ogre API that can be trivial to fix

GLU not found building GL RenderSystem

Postby dermont » Fri Oct 14, 2011 4:50 pm

Not really sure this is a Ogre bug but the Cmake build system doesn't appear to check that GLU exists(OPENGL_GLU_FOUND??) when building the GL rendersystem.

Ubuntu (11.10) has moved more libs, including GLU, to i386-linux-gnu:
Code: Select all
/usr/lib/i386-linux-gnu
/usr/lib/i386-linux-gnu/libGLU.a
/usr/lib/i386-linux-gnu/libGLU.so
/usr/lib/i386-linux-gnu/pkgconfig
/usr/lib/i386-linux-gnu/pkgconfig/glu.pc


The glu.pc package file also doesn't appear to point to the correct location so I guess that either Cmake/Dependencies should update its guesses.

No big deal since one can always set the path to the GLU library in the gui.

Edit:
You can probably ignore the above, clearing the cache and reconfiguring/regenerating the correct version of GLU is found, the previous build was trying to link against GLU in /usr/lib.

This is such a pain having to reconfiguring each cmake project to point to the i386-linux-gnu libs.
dermont
Gnoll
 
Posts: 674
Kudos: 26
Joined: 09 Dec 2004
Location: Kuala Lumpur

Re: GLU not found building GL RenderSystem

Postby jacmoe » Fri Oct 14, 2011 5:38 pm

R'ly ?
Just delete the cache and reconfigure.

Be glad that you're not on Arch Linux or Debian Sid where the libs changes on an almost daily basis. :)

It's not that you have to rebuild the whole thing. :wink:
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, Fueled by Passion.
Ogre AppWizards - Ogre project wizards for VC 8-10, Code::Blocks and KDevelop.
OgreAssimpConverter - command-line to convert models to Ogre format.
TwOgreGUI - wrapper for AntTweakBar GUI library.
I accept donations | Me on Google+
User avatar
jacmoe
OGRE Moderator
OGRE Moderator
 
Posts: 21024
Kudos: 162
Joined: 22 Jan 2004
Location: Denmark

Re: GLU not found building GL RenderSystem

Postby dermont » Fri Oct 14, 2011 6:25 pm

jacmoe wrote:R'ly ?

Yes.

jacmoe wrote:Just delete the cache and reconfigure.

And do this for each build combination default/v1-7/v1-8/static/release/debug? Then repeat for other non Ogre libraries and projects / demos using gtk say.

Anyway it's my own fault I should have created scripts to build the projects passing the install prefix/rpath parameters etc. rather than relying on the CMake gui.

jacmoe wrote:It's not that you have to rebuild the whole thing. :wink:

R'ly ?
dermont
Gnoll
 
Posts: 674
Kudos: 26
Joined: 09 Dec 2004
Location: Kuala Lumpur

Re: GLU not found building GL RenderSystem

Postby jacmoe » Fri Oct 14, 2011 7:21 pm

Delete the CMake cache (CMakecache.txt) and reconfigure.
And that's it.

What's up with you? :)

Don't really see the issue here.
You need to build all your projects anyway, after upgrading a system library.
Deleting the CMake cache and reconfigure is just a small extra step.
And it's not like you upgrade a system lib on a daily basis, or am I wrong?

You could write a small bash script if you want.
Don't need to use the GUI. Just make sure that you pass the right options to CMake.
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, Fueled by Passion.
Ogre AppWizards - Ogre project wizards for VC 8-10, Code::Blocks and KDevelop.
OgreAssimpConverter - command-line to convert models to Ogre format.
TwOgreGUI - wrapper for AntTweakBar GUI library.
I accept donations | Me on Google+
User avatar
jacmoe
OGRE Moderator
OGRE Moderator
 
Posts: 21024
Kudos: 162
Joined: 22 Jan 2004
Location: Denmark

Re: GLU not found building GL RenderSystem

Postby jacmoe » Fri Oct 21, 2011 1:51 pm

I *know* that you loathe that Ogre switched to using CMake.
Learn to live with it. :wink:
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, Fueled by Passion.
Ogre AppWizards - Ogre project wizards for VC 8-10, Code::Blocks and KDevelop.
OgreAssimpConverter - command-line to convert models to Ogre format.
TwOgreGUI - wrapper for AntTweakBar GUI library.
I accept donations | Me on Google+
User avatar
jacmoe
OGRE Moderator
OGRE Moderator
 
Posts: 21024
Kudos: 162
Joined: 22 Jan 2004
Location: Denmark


Return to Papercuts

Who is online

Users browsing this forum: No registered users and 2 guests