New Templates for Xcode 4

Discussion area about developing or extending OGRE, adding plugins for it or building applications on it. No newbie questions please, use the Help forum for that.

Re: New Templates for Xcode 4

Postby NewOne » Wed Jun 22, 2011 8:10 am

masterfalcon wrote: It's related to the LogManager allocation in the sample.

I thought that meant you know about the issue. I tried to --forget it. However the packages have not bin found. I installed the .pkg by just double clicking on it. Now I installed them again via console and now they are listed at pkgutil --packages. How can I uninstall the other ones? Is it enough to just remove the org.... files?

I am running MacOS 10.6, XCode 4.0.2, SDK 3.2 and did not modify the latest prebuilt Ogre folder except of copying the latest Dependencies folder into it. Then I installed the Templates.
NewOne
Gnoblar
 
Posts: 16
Kudos: 0
Joined: 08 Jun 2011

Re: New Templates for Xcode 4

Postby masterfalcon » Wed Jun 22, 2011 9:00 am

I am familiar with the issue, but I believe that it was resolved. BTW, is this an iOS or OS X project?

If there are other packages listed as Ogre templates, you could try forgetting them too. Otherwise you could just delete them from ~/Library/Developer/Xcode/Templates then reinstall.
User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
 
Posts: 4270
Kudos: 130
Joined: 25 Feb 2007
Location: Bloomington, MN

Re: New Templates for Xcode 4

Postby NewOne » Wed Jun 22, 2011 8:26 pm

So I removed the Ogre Folder at ~/Library/Developer/Xcode/Templates/Ogre, removed the Generic Ogre Script.xctemplate in file templates and --forget all ogre packages installed. I am somehow still able to create an Ogre project. The same error appears after compiling.

I am trying to run an Mac OS X app.
NewOne
Gnoblar
 
Posts: 16
Kudos: 0
Joined: 08 Jun 2011

Re: New Templates for Xcode 4

Postby masterfalcon » Wed Jun 22, 2011 10:39 pm

Maybe check to see if you have them in /Developer/Library/Xcode/Templates
User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
 
Posts: 4270
Kudos: 130
Joined: 25 Feb 2007
Location: Bloomington, MN

Re: New Templates for Xcode 4

Postby NewOne » Wed Jun 22, 2011 11:36 pm

Yeah, I have successfully uninstalled the templates reinstalled them and got the same error, which somewhere arises inside the function Ogre::Root. If I add a breakpoint before that I get several warnings, which are not there without the breakpoint:

Code: Select all
 Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(ftsystem.o)" - no debug information available for "builds/unix/ftsystem.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(ftinit.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/base/ftinit.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(ftbase.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/base/ftbase.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(truetype.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/truetype/truetype.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(type1.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/type1/type1.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(cff.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/cff/cff.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(type1cid.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/cid/type1cid.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(pfr.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/pfr/pfr.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(type42.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/type42/type42.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(winfnt.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/winfonts/winfnt.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(pcf.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/pcf/pcf.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(bdf.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/bdf/bdf.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(sfnt.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/sfnt/sfnt.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(autofit.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/autofit/autofit.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(pshinter.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/pshinter/pshinter.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(raster.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/raster/raster.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(smooth.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/smooth/smooth.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(ftgzip.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/gzip/ftgzip.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(ftlzw.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/lzw/ftlzw.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(psaux.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/psaux/psaux.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/release/libfreetype.a(psnames.o)" - no debug information available for "/Users/davidrogers/Documents/Development/Ogre/Dependencies/freetype-2.4.3/src/psnames/psmodule.c".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/libboost_thread-xgcc42-mt-1_46_1.a(thread.o)" - no debug information available for "libs/thread/src/pthread/thread.cpp".

warning: Could not find object file "/Users/davidrogers/Documents/Development/Ogre/ogre-v1-7-3/Dependencies/lib/libboost_thread-xgcc42-mt-1_46_1.a(once.o)" - no debug information available for "libs/thread/src/pthread/once.cpp".


Is there some document anywhere, where it is explained what is needed for a basic project and what files have to be added to the application package?
NewOne
Gnoblar
 
Posts: 16
Kudos: 0
Joined: 08 Jun 2011

Re: New Templates for Xcode 4

Postby alsenes » Mon Aug 01, 2011 7:56 pm

Hi, I have a problem compiling any project crated with the template when I enable GL ES2 support via the template checkbox, both with 1.7.3 SDK and with 1.8 downloaded via mercury, cloned, compiled via the script posted on the wiki and with the template pointing to the 1.8 build dir.

Te problem being:
Lexicological or preprocessor Issue
'OgreGLES2Plugin.h' file not found

on line 46 file OgreStaticPluginLoader.h

45 #ifdef OGRE_STATIC_GLES2
46 # include "OgreGLES2Plugin.h"
47 #endif

Any help would appreciated as I don't have much idea right now, also, what would be the steps needed to activate GLES2 render system without the checkbox?

More information:
After compiling 1.8 with the script (http://ogre3d.org/tikiwiki/Building+Fro ... evelopment) with the correct things changed for 1.8, I have 3 folders, lib, include, iPhoneDependencies

Under lib/release I do have libRenderSystem_GLES2Static.a.
but under include/ogre/plugins and include/ogre/rendersystem I have none references to anything like GLES2
alsenes
Gnoblar
 
Posts: 3
Kudos: 0
Joined: 31 Jul 2011
Location: Valencia, Spain

Re: New Templates for Xcode 4

Postby masterfalcon » Mon Aug 01, 2011 8:20 pm

You will probably need to add a header search path in your project to point to where that header is.
User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
 
Posts: 4270
Kudos: 130
Joined: 25 Feb 2007
Location: Bloomington, MN

Re: New Templates for Xcode 4

Postby alsenes » Mon Aug 01, 2011 8:44 pm

Well I have it working now, basically just copied the whole RenderSystems/GLES2 dir inside include/ogre/rendersystems/GLES2
Now debug logs shows GLES2 rendersystem being initialized. I'll try a couple of shaders to see if it work's correctly but it seems ok now.
alsenes
Gnoblar
 
Posts: 3
Kudos: 0
Joined: 31 Jul 2011
Location: Valencia, Spain

Re: New Templates for Xcode 4

Postby petrocket » Wed Aug 03, 2011 4:04 am

Looks like I'm having the same problem as NewOne. I downloaded the 1.7.3 SDK, templates, dependancies and created a new Ogre project from the template. When I run the project it gets to the 'Creating resource group General' and hangs.

I'm using XCode 4.2 and trying to build a Mac OSX application NOT an iOS application. The iOS application works great, but not the Mac one.

I tried the to uninstall the template packages from the terminal and that failed so I just deleted the folders in /Developer/Library/Xcode/Templates and the re-downloaded & re-installed, but no luv.
Ogre API & Manual | Ogre Wiki

blog | website | work

Follow me on twitter @ twitter.com/petrocket
User avatar
petrocket
Gremlin
 
Posts: 178
Kudos: 9
Joined: 20 Mar 2007

Re: New Templates for Xcode 4

Postby masterfalcon » Wed Aug 03, 2011 4:18 am

Actually the templates are installed in ~/Library/Developer/Xcode/Templates. I need some more info though. What OS is this on?
User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
 
Posts: 4270
Kudos: 130
Joined: 25 Feb 2007
Location: Bloomington, MN

Re: New Templates for Xcode 4

Postby petrocket » Wed Aug 03, 2011 6:08 pm

Oh sorry that was a typo on my part - I did delete the ones you mentioned
masterfalcon wrote:Actually the templates are installed in ~/Library/Developer/Xcode/Templates. I need some more info though. What OS is this on?


I'm on OSX 10.6.8 on an intel MacBookPro.

My Xcode version is 4.2 (4C104) and I have the IOS 5 dev kit installed. I do recall installing fink and maybe Macports a while ago but I'm pretty sure they have been deleted.

Couple screenshots:
project-settings-console.jpg

stack.jpg
Stack Screenshot


And the project files with the media folder removed.
OSXTestProject.zip
Project with media folder removed because of forum file upload size limit
(31.4 KiB) Downloaded 75 times


Not sure if this has anything to do with it, but the plugins.cfg has the PluginsFolder set to ./ but the actual renderssytem_gl file is in /Plugins inside the .app package. Should the plugins folder path be something like ./Plugins or ./../Plugins ?

Well, I tried that and it didn't help, but dunno if I was on the right track.
Ogre API & Manual | Ogre Wiki

blog | website | work

Follow me on twitter @ twitter.com/petrocket
User avatar
petrocket
Gremlin
 
Posts: 178
Kudos: 9
Joined: 20 Mar 2007

Re: New Templates for Xcode 4

Postby petrocket » Wed Aug 03, 2011 7:54 pm

Well, I came up with a temporary fix.

If I comment out the m_pLog lines and the new Ogre::LogManager(); line and append
Code: Select all
m_pLog = Ogre::LogManager::getSingleton().getDefaultLog();


After m_pRoot is created like so:

Code: Select all
    //new Ogre::LogManager();

   //m_pLog = Ogre::LogManager::getSingleton().createLog("OgreLogfile.log", true, true, false);
   //m_pLog->setDebugOutputEnabled(true);
   
    String pluginsPath;
    // only use plugins.cfg if not static
#ifndef OGRE_STATIC_LIB
    pluginsPath = m_ResourcePath + "plugins.cfg";
#endif
   
    m_pRoot = new Ogre::Root(pluginsPath);//, Ogre::macBundlePath() + "/ogre.cfg");
   
#ifdef OGRE_STATIC_LIB
    m_StaticPluginLoader.load();
#endif
   
   if(!m_pRoot->showConfigDialog())
      return false;
   
    m_pLog = Ogre::LogManager::getSingleton().getDefaultLog();


Then it runs fine!
Ogre API & Manual | Ogre Wiki

blog | website | work

Follow me on twitter @ twitter.com/petrocket
User avatar
petrocket
Gremlin
 
Posts: 178
Kudos: 9
Joined: 20 Mar 2007

Previous

Return to Developer talk

Who is online

Users browsing this forum: No registered users and 3 guests