Error compiling ogredotnet(using OgreDotNet.Cegui;)


06-06-2006 20:24:30

good evening.
I'm having quite a bit of trouble compiling the OgreDotNet project, and it seems to be coming from the Cegui part.

Basically, my compiler can't find OgreDotNet.Cegui when I do a batch build.
I'm guessing that this stems from these errors:
...\ogredotnet\OgreNet.Cegui\OgreBindings_Cegui.cs' could not be opened ('The file cannot be found. ')
I've tried looking on this forum, I've tried restarting my IDE, but it doesn't seem to help, so some assistance would be appreciated.

// Eric


06-06-2006 20:53:45

You need to copy OgreSDK\Samples\Include\OgreCEGUI*.h to OgreSDK\Include.

befor running batch build if you don't have GangstaWrapper removed GangstaBindings, GangstaDotNet and DemoGAPyramid projects.

Also need to rightclick and compile the *Bindings.i files in for each of the bindings projects (CeguiBindings.i, (GangstaBindings.i), OgreBindings.i, OgreBindings.Cegui.i). The batch build should be ok then.