OgreDotNet build problems


11-09-2006 10:10:20

Hello !

(I precise that I read all the previous topics about this subject, and I think that I have configured compilers and SWIG correctly)

I tried to compile OgreDotNet against Ogre 1.2.2 SDK prebuilt libraries for VS8.0 Express :
I had to move all the OgreSDK/samples/include/*.h to OgreSDK/include folder in order that SWIG find them.
I had to convert some .h and .cpp files in ogredotnet/CeguiNet and ogredotnet/ogrenet folder from Mac format to Dos format using Mac2Dos tool (let's find it easily into google).
I didn't care about Gangsta (leave errors and no builds).
The C++ build process made several warnings but no errors.
I tried to build C# project with VC8.0 Express and it works fine with some warnings.
With I launch the compiled .Net samples I get this message :

### Exception Une exception a été levée par l'initialiseur de type pour 'OgreDo
à OgreDotNet.OgreBindingsPINVOKE.new_Root__SWIG_3()
à OgreDotNet.Root..ctor()
à OgreDotNet.ExampleApplication.Setup()
à OgreDotNet.ExampleApplication.Start()
à DemoCelShading.cCelShading.Main(String[] args)
### Exception La référence d'objet n'est pas définie à une instance d'un objet.

à DemoCelShading.cCelShading.Dispose()
à DemoCelShading.cCelShading.Main(String[] args)

Finally, I browse this forum and redo all this process with OgreSDK 1.2.0.
I get the same Error message !

Please give me some advices.


15-09-2006 02:38:10

did you move all the dlls to the correct location?


16-09-2006 13:27:41

I put all the dlls in the bin/debug (or either bin/release) path.
Are they the correct location ?


18-09-2006 12:29:10

Hi Fruit,

I'm doing the same thing. I have compiled Ogre 1.2.2. I copied over all the dll's and exe's in the SDK directory. Did you find a solution yet?

Here is the error I'm getting:

### Exception The type initializer for 'OgreDotNet.OgreBindingsPINVOKE' threw a
n exception.
at OgreDotNet.OgreBindingsPINVOKE.new_Root__SWIG_3()
at OgreDotNet.Root..ctor()
at OgreDotNet.ExampleApplication.Setup()
at OgreDotNet.ExampleApplication.Start()
at SkyBox.SkyBoxApplication.Main(String[] args)
### Exception in Dispose Object reference not set to an instance of an object.
at OgreDotNet.ExampleApplication.Dispose()
at SkyBox.SkyBoxApplication.Main(String[] args)



18-09-2006 21:33:31

I had no time for that since my first try, so I had no new solutions. So maybe here is an intersting thread :


I will study it later...