Does anyone run ogredotnet on linux?


01-10-2006 07:58:34

Since last week I've tried to install ogredotnet on my computer. I've got a lot of archives, the prebuild dlls, the magic tar.gz file. I visited a lot of web forum but, e never had sucess.
Now, I have three problem, with different install types:
- The first one is with the tar.gz type, when I run configure, the returned error text is:
checking for ZZIPLIB_CFLAGS...
checking for ZZIPLIB_LIBS...
configure: error: Package requirements (zziplib) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the ZZIPLIB_CFLAGS and ZZIPLIB_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
But, this variable PKG_CONFIG_PATH is not setted! If I set it then wich value it will receive?

-Second. With the prebuild dlls. I copied the dll to /usr/lib/mono/2.0/ but, when I run some program then errors appears.
-Third. With the tar.gz file the error is:
### running swig on OgreBindings ###
Package OGRE was not found in the pkg-config search path.
Perhaps you should add the directory containing `OGRE.pc'
to the PKG_CONFIG_PATH environment variable
No package 'OGRE' found
Unable to find 'OgreBindings.i'
./ ( ### ERROR, swigging OgreBindings ### )
Once the PKG_CONFIG_PATH appears.

So, anyone here has an idea for any question? And, the final question: I need the c++ Ogre version to use OgreDotNet?

That's all.

P.S.: They should write a tutorial on OgreDotNet Wiki, there are so many people that don't have a sucefull install.