MONO_DEPENDENCY trouble with ./


16-04-2006 16:18:34

Hi there,

I just downloaded OgreDotNet and followed the instructions in
README. When runs ./configure I get the following error:

checking for MONO_DEPENDENCY... configure: error: mono 1.1.9 or higher is required

strange, since I installed mono 1.1.15 just a couple of days ago:

$ mono --version
Mono JIT compiler version 1.1.15, (C) 2002-2005 Novell, Inc and Contributors.
TLS: normal
GC: Included Boehm (with typed GC)
SIGSEGV: normal
Disabled: none

any hints, tipps, suggestions?

thanks! :)


16-04-2006 16:52:44

Perhaps you hasn't update MONO_PATH in export, and this is pointing to the old dependencies. I think...


16-04-2006 16:59:23

what does pkg-config tell you ?
$ pkg-config --modversion mono

where do you have mono installed, where is the mono.pc? it needs to be ether in /usr/lib/pkgconfig or one of the paths in the environment variable PKG_CONFIG_PATH

$ set | grep PKG_CONFIG_PATH


17-04-2006 11:58:09

thanks for your replies :)

this is what I get:
$ pkg-config --modversion mono

$ set | grep PKG_CONFIG_PATH

the mono.pc is in /opt/mono-1.1.15/lib/pkgconfig/ so this seems
to be right. The mono installer modified my ~/.bashrc and inserted
export PATH="/opt/mono-1.1.15/bin:$PATH"
export PKG_CONFIG_PATH="/opt/mono-1.1.15/lib/pkgconfig:$PKG_CONFIG_PATH"
export MANPATH="/opt/mono-1.1.15/share/man:$MANPATH"
export LD_LIBRARY_PATH="/opt/mono-1.1.15/lib:$LD_LIBRARY_PATH"


17-04-2006 20:56:57

hmm... Try this, in (yes on line 21 take the double quotes off the values in the test. Then run again.
if test "x$has_mono" = "xtrue"; then
if test x$has_mono = xtrue; then


18-04-2006 19:45:18

That did it :)

checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for MONO_DEPENDENCY... yes
checking for mono... no
checking for gmcs... no
checking for OGRE... yes

thanks again for your help :)