OgreAL Under Codeblocks/MinGW (Read before asking)

t0tAl_mElTd0wN

09-02-2007 05:04:39

...does not work at the moment. I'm pretty much burnt out trying to solve linker errors. If anyone doesn't have Visual Studio and would like a compiled library let me know, but I just don't have the energy to get this working right. Anyone else is more than welcome to try, and we'll certainly help where we can, if you really need this to compile in Codeblocks.

So. In short, although the SVN Head and the version numbered releases have Codeblocks projects present in them, chances are they won't work, and I don't know why. I still plan on getting it working, but not now, and probably not real soon. Sorry. :?

Deamon

10-02-2007 14:46:41

Hell, i'm doomed :x

I need it soon. Maybe the devs of ogg and vorbis should be asked to provide a project for CodeBlcoks nad MingW ?

Deamon

10-02-2007 14:47:16

I'm woundering would it work when i would use Code::Blocks and the MSToolkit ?

CaseyB

10-02-2007 15:27:12

It should, the issue is mainly with GCC and not Code::Block, so using the MS Toolkit should work fine. You'll still need to set up the paths correctly as I am not sure of their state in the project files in SVN at the moment.

Deamon

11-02-2007 01:59:05

I have to wait till i got my rig with XP cose the VS toolkit cannot be installed on WinME. Then i will try it ASAP. But i still hope it can be made run on GCC, so that i and others don't need to abandone it.

CaseyB

11-02-2007 05:18:18

Yup, we're working on it! I know that it compiles just fine under Linux, so there shouldn't be any trouble with MinGW, it's just a question of setting it up correctly.

Deamon

11-02-2007 07:57:38

Yup, we're working on it! I know that it compiles just fine under Linux, so there shouldn't be any trouble with MinGW, it's just a question of setting it up correctly.

It would be great if you tell what the problem was. I lack competence to solve this on my own. So i'm woundering what the actualy problem is ?

You say it's just a question of settings. So after all it doesn't matter what compiler you use as long the settings are right ?

I would conclude from this that each compiler have very individual settings/option that have to be set properly ?

The code don't have to be changeg for each compiler haven't it ?

What do you think will this problem take long to be solved ?

Is this a workintense problem ?

CaseyB

11-02-2007 08:16:31

The trouble is that everyone is getting linker errors and noone cam figure out why. I don't even have Code::Blocks set up at the moment so I cannot say what exactly the problem is or how lng it will be until it's fixed.