Problem with compiling game tutorial. Novice requires help.


14-07-2007 12:56:33

Heya people.
I'm kind of fatigued by now, so I'll try to keep things short but detailed.
Currently using VC 2005 compiler and Ogre 1.43(Eihort).
Just realised that one of the game tutorials in my text requires OgreAL.
Followed Casey B's setup and install closely*Thanks alot Casey, it really helps someone as clueless as I am to manage through things*.
Managed to compile OgreAL successfully(abeit with many warnings).
Started compiling my pong tutorial.
...the following error came up:

"c:\ogre\ogreal\include\ogrealprereqs.h(12) : fatal error C1083: Cannot open include file: 'AL/alut.h': No such file or directory"

And yes, I downloaded and installed OPENAL and downloaded the freealut binaries too.
Already had my environmental variables set as well.
Can anyone identify what actually went wrong?

Thanks in advance.



23-07-2007 18:37:08

Search your includes directory/directories for alut.h. You may have moved it out of the AL/ directory, in which case it wouldn't be found by the include directive, which is #include "AL/alut.h". You can just go to the #include line where it says the filename, and try removing the AL/ . If it still doesn't work, you should locate the file on disk with the Windows file search function and make sure that the directory it's located in is one of the directories listed as a search directory for included files in your project settings. You can remove or add the AL/ to that as necessary. If it still doesn't work, post your project settings for include directories, the code where the #include happens, and the detailed list of the file search for alut.h, and it should be clear where the disjoint occurs.



24-07-2007 02:43:45

Sorry about not getting back to you sooner, but Jekteir is right, have a look in the freealut dir and see if alut.h is in fact in the AL folder. You should see somthing likefreealut-1.1.0-bin/include/AL/alut.h