Can't hide scrollbars on a sheet anymore?

Chaster

19-03-2008 15:57:48

Hello,

I just updated to the latest SVN of QuickGUI and everything seems fine except that the function Sheet::allowScrolling(bool) is no longer there. My application specifically needs to NOT have scrollbars, so this is a problem. I searched around through the classes a bit for the equivalent, but found nothing. How can I get rid of the scrollbars on my sheet? (they're killing performance of my app too)..

Thanks,

Chaster

kungfoomasta

19-03-2008 17:32:14

I removed this and forgot about the need of not having scrollbars. :oops:

I will add in a function tonight to disable the scroll pane from functioning, at least 1 other user has this need also.

Chaster

20-03-2008 04:33:22

Thanks very much KFM!

Chaster

kungfoomasta

20-03-2008 06:36:46

Ok its committed.

Panel::disable/enableScrollPane()

You can also disable/enable the ScrollPane directly. (mPanel->getScrollPane()->disable().

I only briefly tested it, but it should work.

Chaster

21-03-2008 05:55:58

Ok its committed.

Panel::disable/enableScrollPane()

You can also disable/enable the ScrollPane directly. (mPanel->getScrollPane()->disable().

I only briefly tested it, but it should work.


Thanks, I'm downloading now. Will report back if I have any difficulties.

Thanks again!

Chaster

Chaster

22-03-2008 03:52:48

Ok its committed.

Panel::disable/enableScrollPane()

You can also disable/enable the ScrollPane directly. (mPanel->getScrollPane()->disable().

I only briefly tested it, but it should work.


Hm, doesn't seem to work. I tried both ways you describe above, and just for kicks, I also tried using mPanel->getScrollPane()->hide()... Which also didn't work...

I tried to trace into the code and see where things were going awry, but I'm not familiar enough (actually, at all) with QuickGUI's source to be much help... :(

Chaster

kungfoomasta

22-03-2008 08:37:12

What widget are you using?

Do the scrollbars appear on creation of the widget, or after adding an item?

Chaster

23-03-2008 20:43:56

I'm just using the default sheet. Interestingly, the scrollbars don't appear at the same time, the bottom (horizontal) scrollbar appears at start, but the side (vertical) scrollbar appears only when I move the mouse to the vertical edges.

The only widgets I am using are images, buttons, and progressbars.

Hope that helps...

Chaster

Chaster

26-03-2008 02:38:50

*BUMP* Any news on this KFM? If not, that's okay.. I know you are mucho busy with all kinds of stuff... FYI, I reverted back to SVN revision 340 and that is working fine for me for now..

Chaster

kungfoomasta

26-03-2008 06:40:23

Sorry Chaster. I am keeping a list of issues that have been raised, but I've been spending all my time on new QuickGUI developments. I don't want to go in detail about what I'm working on, but its a lot to do, and I'm hoping to produce something great soon. :twisted:

Chaster

29-03-2008 04:21:20

Sorry Chaster. I am keeping a list of issues that have been raised, but I've been spending all my time on new QuickGUI developments. I don't want to go in detail about what I'm working on, but its a lot to do, and I'm hoping to produce something great soon. :twisted:

No worries! Sounds like you have something really cool cooking, so I'm looking forward to it!

Chaster