Compile ETM on Ubuntu 9.04


28-09-2009 20:13:24

Hi all !

I worked on Ogre3D since 2 or 3 week and i am on ubuntu/linux 9.04. I've discovered the Editable Terrain Manager this day and i want to tried it. (I need an editable terrain manager 8) ) But when i tried to compile it on ubuntu :

arkada @ ~/Bureau/etm-2.3.1 > make
g++ -O2 `pkg-config OGRE --cflags` -Iinclude -fPIC -c -o obj/ETBrush.o src/ETBrush.cpp
Assembler messages:
Fatal error: can't create obj/ETBrush.o: No such file or directory
make: *** [all] Erreur 1

This is my small problem. I think it's only a location files problem.
But i don't now how i can solve this problem.
If you can help me ?



28-09-2009 20:24:22

Oh ! I'm sorry, i've retried after created a folder "obj",and the beginning of the compilation works fine :lol:
But now i've another problem :

// Compilation code // Bla Bla Bla ...

/usr/bin/ld: cannot open output file bin/ No such file or directory
collect2: ld a retourné 1 code d'état d'exécution
make: *** [all] Erreur 1

Same question ? :roll:


06-10-2009 14:26:45

Looks like you were on the right track. I was able to compile and install completely with no issues after creating both directories.

mkdir obj
mkdir bin
sudo make

Great Success!