Linux build issues[solved]


09-03-2010 02:28:49

First, greetings to everyone here. I thought I'd give MyGUI a try, and after breezing through the beautiful cmake system (no complications to speak of!), I got 40% done with the make before encountering this:

[ 1%] Building CXX object MyGUIEngine/CMakeFiles/MyGUIEngine.dir/src/MyGUI_Guid.cpp.o
/home/calder/Developer/MyGUI/MyGUIEngine/src/MyGUI_Guid.cpp:26:23: error: uuid/uuid.h: No such file or directory
/home/calder/Developer/MyGUI/MyGUIEngine/src/MyGUI_Guid.cpp: In static member function ‘static MyGUI::Guid MyGUI::Guid::generate()’:
/home/calder/Developer/MyGUI/MyGUIEngine/src/MyGUI_Guid.cpp:172: error: ‘uuid_generate’ was not declared in this scope
make[2]: *** [MyGUIEngine/CMakeFiles/MyGUIEngine.dir/src/MyGUI_Guid.cpp.o] Error 1
make[1]: *** [MyGUIEngine/CMakeFiles/MyGUIEngine.dir/all] Error 2
make: *** [all] Error 2

If anyone has any suggestions for dealing with it, the help would be much appreciated.


EDIT: Figures, the minute I post I finally figure it out. *doh*. Solved with a simple:
sudo apt-get install uuid-dev

EDIT 2: After that everything went exceedingly smoothly! Thanks for an amazingly slick build system; you have no idea how much potential stress and frustration it alleviates to have everything just work!