MYGUI 3.0.1 on N900 - MYGUI can't load resources [solved]


12-04-2010 12:22:53

I have built an application using Ogre 1.7 and MYGUI 3.0.1 on Nokia N900 (Maemo Linux)
I have added the resource directory for MyGUI under [General] in resources.cfg Filesystem=Media/MyGUI_Media
When i start the application Ogre can load and work with resources but MyGUI can't. "Cant find core.xml" etc.

I can run the MyGUI demos on N900, but they use resources.xml? I added resources.xml to my binary dir and fixed it for my app, but that didn't help.
i run MyGUI 3.0 and Ogre 1.7 in windows and that works fine, only difference now is Ogre 1.7 and MyGUI 3.0.1, can that be a problem?



12-04-2010 12:33:33

Well, resources.xml used same way as resources.cfg. It is used only by demos/tools, so you don't need it for your application if you not using BaseManager class from MyGUI Common folder.
Check your paths and resources.cfg twice.


12-04-2010 12:37:41

Problem solved...
I wrote in the previous post that my path was:
the actual path i had was Filesystem=Media\MyGUI_Media :oops:

But i changed "\" to "/" and now it works great. :D