Problems with SVN


12-03-2013 17:23:39

Error: REPORT of '/svnroot/my-gui/!svn/vcc/default': Could not read response body: An
Error: existing connection was forcibly closed by the remote host.
Error: (

Get this mid-update every time right now...


12-03-2013 18:56:27

That could be due to big update we did recently. Your or remote side closes too long update.
Also sourceforge changed default repository addresses, try to update from
svn:// (read only)


12-03-2013 19:30:43

In the end I tried a clean checkout and that worked fine.

I noticed a lot of SVN changes, what was the big update for exactly? Any change-notes or anything I can see?


12-03-2013 21:04:15

We are not using boost in MyGUI and the only reason why it exist in CMake is that Ogre use and OgrePlatform won't compile without includes.
I can try to reproduce problem on my computer, but now I have only few guesses - it could come from Ogre's header and directive in code, or it could come from findOgre.cmake script.

What about big commit - we are switching to MIT license. No code changes, just changed files headers.


12-03-2013 22:13:24

Oops, I moved that question to another thread. Will cross link :)


13-03-2013 09:45:55

What about big commit - we are switching to MIT license. No code changes, just changed files headers.

Has this change already taken place? THe two .h files I looked at still said:
This file is part of MyGUI.

MyGUI is free software: you can redistribute it and/or modify
it under the terms of the GNU Lesser General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

MyGUI is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License
along with MyGUI. If not, see <>.


13-03-2013 20:19:03

Commit were made 10 days ago, revision 5200. I found three files (not in core files) where old license wasn't replaced, but everything else is fine.
Current latest revision is 5202.


13-03-2013 20:28:52

I'm very confused then. I got a new checkout from scratch yesterday and it's r5198 which is what SVN repo browser is telling me as well.

You mentioned URL had changed, did you mean you actually moved the repo or that both URLs point to same repo now?

edit: looks like 2 separate repos? Where is the sticky thread ;)


14-03-2013 15:35:22

Sourceforge suggested to "upgrade project", I confirmed that and repository address changed. It is very odd, that there are two addresses now. Looks like a bug, I'll try to fix that in few days.