Error building libs MyGUI (MinGW) [SOLVED]

Lord Fers

04-09-2015 04:00:59

Sorry for my bad english; I was trying to define _countof on my own, but takes different errors because of that , so I do not know what to do . And I generated all units and all, I had to get into the MinGW libs but because I did not recognize either the folders.



04-09-2015 09:42:51

Try to replace "_countof(wstr)" with "2", does everything else compiles?
Meanwhile I'll try to make a proper fix for this.


04-09-2015 09:59:54

Oh, just get newer sources. This was fixed a long time ago. MyGUI 3.2.1 or newer release would work.

Lord Fers

04-09-2015 16:01:05

In MyGUI 3.2.2 MyGUI_Singleton tells me that there undefined references (in msInstance) , and MyGUI 3.2.1 tells me there undefined references in `MyGUI::Timer::getMilliseconds()'|.
Image MyGUI 3.2.2:


05-09-2015 11:25:25

Am I right, that you resolved singleton issue somehow?

Lord Fers

05-09-2015 15:20:13

Yes , I do not know how or why, but using CMake 2.8.3 worked. Now I have another problem , where I created a thread about it.