Error When Compiling With Ogre 1.6.0 (Shoggoth)


31-08-2008 06:49:53

I just checked out Ogre 1.6.0 (Shoggoth) (stable) from SVN, and it built fine. However, when I built MyGUI with it, it generated this error:-
MyGUI_RenderItem.cpp: In member function ‘void MyGUI::RenderItem::initRenderState()’:
MyGUI_RenderItem.cpp:114: error: no matching function for call to ‘Ogre::RenderSystem::_setAlphaRejectSettings(Ogre::CompareFunction, int)’
/usr/local/include/OGRE/OgreRenderSystem.h:664: note: candidates are: virtual void Ogre::RenderSystem::_setAlphaRejectSettings(Ogre::CompareFunction, unsigned char, bool)

I myself am going to look into it, but I wanted to tell you too. :)

solved it by changing the line to:
mRenderSystem->_setAlphaRejectSettings(Ogre::CMPF_ALWAYS_PASS, 0, true /*should this be false?*/);
But then, I get this:-
make[2]: Entering directory `/home/nikki/Development/Libraries/ogre/mygui/MyGUIEngine/include'
make[2]: *** No rule to make target `MyGUI_AlignInfo.h', needed by `all-am'. Stop.
make[2]: Leaving directory `/home/nikki/Development/Libraries/ogre/mygui/MyGUIEngine/include'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/nikki/Development/Libraries/ogre/mygui/MyGUIEngine'
make: *** [all-recursive] Error 1



31-08-2008 16:51:11

After further investigation, it seems that there's something wrong with the Makefiles, because it doesn't even work with Eihort (1.4.9).

I'm lazy now, so I'm not going to fix it. I'm hoping Altren will look soon :)


01-09-2008 23:35:08

I have the same problem when trying to compile MyGUI using the version Shoggoth de Ogre.


02-09-2008 07:29:56

The problem is fixed by changing that line above, but the it seems that a file called 'MyGUI_AlignInfo.h' is missing or something. I think we can just get it from a later revision and try.


09-03-2009 04:38:57

Hello !

I have the same error ! Set 'true' or 'false' for 3th argument of _setSceneBlending(...) ???



09-03-2009 12:30:28

Just get MyGUI from svn.