Problems with Debug Build [solved]


14-12-2008 06:42:19

*EDIT* Okay, that was definitely the problem (using FreeType compiled with VC7 instead of VC9). I *thought* i was using the newer version since I redirected the project to use Ogre's dependencies. What I didn't account for was my Ogre dependencies had the OLD FreeType 2.30 (left over I guess from older installation). I redirected AGAIN to use FreeType 2.35 (which is also in my Ogre Dependencies) and then everything works great.


Hi Everyone,

*EDIT* Upon more testing, I find that the Debug build crashes IMMEDIATELY (I can't even step into it with the debugger) with a "failed to initialize" error... What the heck?

I'm trying to get the MyGUI demo (Demo_Gui) to build and run and am encountering problems with the debug build. The release build works fine, but when I try to run the debug build, it crashes almost immediately with a pretty low level error. I haven't traced into it yet, but I was wondering if anyone had a clue...

I am using VC2008 Express Edition SP1 with the latest Ogre from SVN (and the MyGUI from SVN version 8.09 I think). Like I mentioned, Release build compiles and works fine. Oh, and I'm using the Freetype from Ogre Dependencies, not the Freetype from MyGUI (tried both, no difference).

Any clues as to where I should look first?

By the way, I had to comment out a call to "#include "OgreMemoryManager.h"" in DemoKeeper.cpp to get it to compile...



14-12-2008 16:07:26

Just move your eyes up.
Sticky: FreeType deps in VC9.0