Strange error !


07-03-2009 09:57:53


I use Visual C++ 2008, OgreSDK 1.6.1 (VC90), MyGUI 2.2.0 RC1 (Source). I compile MyGui normally. But when i run my app (or test Demo_ItemBox ...). There is a message box (error) like:

"The procedure entry point?allocateBytes@NedAllocPolicy@Ogre@@SAPAXIPBDH0@Z could not be located in the dynamic library OgreMain.dll"

Anybody help me ?



07-03-2009 11:17:15

He-he, I'm not sure that we tested MyGUI with ogre 1.6.1, exactly with NedMalloc (P.S. Altren, do you have enabled ). And we haven't support of Ogre Memory managers.
But, I think problem might be not in MyGUI.
Are you sure that ogre-demos works? And you link to wright version (debug/release).
If demos works... Get trunk from our SVN. May be problem will be solved. May be not.


07-03-2009 16:08:38

I'm always using latest Ogre with MyGUI, but we haven't tried older MyGUI versions with Ogre 1.6, so you should checkout fresh MyGUI sources from svn. And you should also check that you using Ogre dll and lib files not from different versions of Ogre, because looks like you do.