Noob reminder: check for malformed resources.cfg, else crash


07-04-2010 20:20:34

I know this is a basic error but I'll put this out since we're all new at one time (and the forum would not let me delete this post :? ). Ensure that the resources.cfg is sane else createDefinedTexture may segfault without an error/log message. I was scratching my head for quite a while looking for a bad pointer in my code until I checked the cfg.


07-04-2010 20:22:53

Huh, weird. does the demo app work?
which OS and and PC architecture?


07-04-2010 20:25:44

Sorry, a premature posting. What I meant to say was that I have just begun to work with the ogrevideo plugin and have gotten everything to compile and install under linux except for the demo player which I did not bother with as I am not using CEGUI. I'm not sure if the crash is caused by my code, an invalid resource (or location), or by the plugin. It crashes at "createDefinedTexture". Any ideas anyone? TIA


07-04-2010 20:32:50

well, could be your code, could be something on your OS. you're using Linux, right?

i suggest you try compiling the demo app, if that doesn't work, then the problem is in the library itself.


07-04-2010 20:38:21

I think I have found the problem -- I am stupid :D

TheoraVideoManager* video_manager(new TheoraVideoManager(1));

should be:

OgreVideoManager* video_manager(new OgreVideoManager(1));


07-04-2010 20:51:33

Harr Harr Harr [bitchslap!] :D

yes, TheoraVideoManager is libtheora's manager, and OgreVideoManager is ogre video plugin's. the second one handles material scripts etc while the first one controls playback and distribution of labor (decoding etc)


07-04-2010 21:13:16

Well I guess I'm stupider than I thought, as it has the same error. Has anyone compiled the demo player against the latest CEGUI (0.7.1)? Because, it ain't compiling. Sorry, I haven't messed with Crazy Eddie since version 0.5.x -- I have since built my own UI directly in Ogre 1.6.4 (and no, it's not worth the effort :D ). Thanks for the help and sorry for being a pain.


07-04-2010 21:15:14

I tried it against cegui 0.6.x

btw, I have also developed a simplistic gui system we're using for my company's iphone games, and yeah, it was worth it!
Cegui is cool, but it's so biiiiig!


08-04-2010 01:42:25

Ok, I got the demo player running (but not really working). The Ogre window with an apparently working CEGUI screen with some widgets on the left hand side and a large empty square panel on the right. Basically, it works but the video does not show up? Any ideas? TIA.


Ogre 1.6.4
CEGUI 0.6.1
OIS 1.2
Linux and OpenGL


08-04-2010 07:13:57

does the slider on the bottom move?

and no, I have no idea, I'll have to look into it; it could either be that the video isn't decoding, which is unliekely because libtheoraplayer works fine under linux, or some ogre related bug, ie. pixel format.


08-04-2010 12:20:29

Success!!! (Except, no audio yet :( ) The OgreVideoManager object was not getting "frameStarted" event. I called from within the DemoApp::frameStarted and that fixed it. Thanks for helping me out with this!