Running video problems


25-12-2008 17:41:02

I've built plugin and sample (revision 30). I use Ogre Shoggoth (1.6.0).

Firstly,I found a strange, that
TheoraVideoClip* clip=c->getMovieNameClip("clip.ogg");
returns 0. I run it by debug and found that my file "clip.ogg" was written as a "clip.ogg "(filename and a space!). I check my file name - al wright. I think it may be a bug. So, I set: c->getMovieNameClip("clip.ogg "); and it works :) .

Secondly, my video isn't shown. I've changed rendering systems and correct ogg files. But can't see the video. Debugging it, I can only say, that's it never goes here (in if). May be it's helps.

if( mFramesReady )
double nowTime=getMovieTime();
TheoraFrame* frame;
// we go through the list of available frames and try to find one suitable for presentation
// if a frame's time to display has ended, it will be dropped, which will hopefully happen
// rearely.
// if all frames are dropped, the last still get's displayed.
if (mTimeOfNextFrame > nowTime) return;
while (mFrames.size())


25-12-2008 22:48:34

Thanks for your report! I'll look into it as soon as I am able.

I have not tried running the project on Ogre 1.6 since I started it, so there might be some problems there.