Integration of 0.5.1 ini Ogre 1.7.1 [solved]


07-06-2010 23:47:41

Hi guys,

i compiled Hydrax successfully. But if I copy the dlls in my project and add the plugin to the plugins.cfg my Project doesn't start anymore.
Ogre.log says:

00:09:56: Loading library .\Hydrax
00:09:57: OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library .\Hydrax. System Error: Das angegebene Modul wurde nicht gefunden.

in DynLib::load at ..\..\OgreMain\src\OgreDynLib.cpp (line 91)


Has anyboy a explanation for that or a tutorial how to set up a simple scene?



07-06-2010 23:48:46

btw. i was wondering that the compilation of hydrax debug used the OgreMain.dll instead of OgreMain_d.dll. Is that correct?


08-06-2010 09:59:12

oops i saw, that hydrax isn't supported by ogre 1.7.1 yet.
Will it be updated soon?



08-06-2010 16:33:25

Hydrax does support 1.7.1 and it will use whichever OgreMain.dll you linked to it at compilation. Also if you're using VC++ then if i remember correctly you need to change the project settings to link to Hydrax.dll


09-06-2010 00:11:48

ah ok... i think my problem was that i tried to include is as a plugin (in plugins.cfg) which is not necessary.
including the header and running the program works now. I hope this has fixed my problem.
I will let you know soon.

Thanks for the tip to include the "dll" - i think you meant libs ;) but that helped me to find this solution!


14-06-2010 08:37:48

it worked very well. [solved]