[Solved]No textures loading


27-08-2010 16:50:09

Hello all.

I'm having a problem when I run Hydrax as a part of an app that I created. The water is not rendered from top to bottom or bottom to top but when I get close to the surface of the water while under it I can see that the water is loaded there's just no textures.

Here is an example image:

Here is my code

mSceneMgr->setSkyBox(true, "Examples/SpaceSkyBox", 99*3, true);

// Hydrax initialization code ---------------------------------------------
// ------------------------------------------------------------------------

// Create Hydrax object
mHydrax = new Hydrax::Hydrax(mSceneMgr, mCamera, mWindow->getViewport(0));

// Create our projected grid module
Hydrax::Module::ProjectedGrid *mModule
= new Hydrax::Module::ProjectedGrid(// Hydrax parent pointer
// Noise module
new Hydrax::Noise::Perlin(/*Generic one*/),
// Base plane
Ogre::Plane(Ogre::Vector3(0,1,0), Ogre::Vector3(0,0,0)),
// Normal mode
// Projected grid options
Hydrax::Module::ProjectedGrid::Options(/*264 /*Generic one*/));

// Set our module

// Load all parameters from config file
// Remarks: The config file must be in Hydrax resource group.
// All parameters can be set/updated directly by code(Like previous versions),
// but due to the high number of customizable parameters, since 0.4 version, Hydrax allows save/load config files.

// Create water

// Hydrax initialization code end -----------------------------------------
// ------------------------------------------------------------------------

// Load island

->createTechnique()); */
mRoot->addFrameListener(new ExampleHydraxDemoListener(mWindow, mCamera, mSceneMgr));

The Create Scene Code is almost( missing some light declarations and such) identical to the demo's so I have no Idea why this is happening.

Also, as a side note, I am not using any shadows so there should be no problems with hydrax and stencil shadows.

EDIT: To fix this problem I replaced this line:

// Base Plane
Ogre::Plane(Ogre::Vector3(0,1,0), Ogre::Vector3(0,0,0)),

with this one:

// Base Plane
Ogre::Plane(Ogre::Vector3::UNIT_Y, Ogre::Real(0.0f)),


30-08-2010 23:33:51

does anybody have an answer to this?


31-08-2010 14:19:32

After inspection of my Ogre.log file I was able to pinpoint this error:

05:32:07: Error loading texture HydraxDepthReflectionMap. Texture layer will be blank. Loading the texture failed with the following exception: OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource HydraxDepthReflectionMap in resource group Hydrax or any other group. in ResourceGroupManager::openResource at ..\..\..\..\OgreMain\src\OgreResourceGroupManager.cpp (line 753)

Anybody know how to solve this?


01-09-2010 13:47:07

I was able to solve that problem and I have zeroed in on the problem with Hydrax: There is no texture on the water. I think this is a problem with RTT but I have absolutely no idea how to solve it and my google searches have proved fruitless. If anyone has ANY idea how to solve the "black water" problem I will greatly appreciate it.


31-10-2010 03:06:15

how did you solve it? didnt underastand..