[SOLVED] Clouds not working


02-02-2010 09:30:33


I don't seem to make the clouds working.

I am new to Caelum, but I managed to create a working environment, with the sun moving, day-night cycle and now i want to add some clouds.

i use the following initialization:
componentMask = static_cast<Caelum::CaelumSystem::CaelumComponent> (
Caelum::CaelumSystem::CAELUM_COMPONENT_SUN |
Caelum::CaelumSystem::CAELUM_COMPONENT_MOON |

and for the clouds i used
Caelum::FlatCloudLayer *layer = mCaelumSystem->getCloudSystem()->createLayerAtHeight(1000);

Is there something else i need to consider for default clouds?
I looked for an answer and did not find any.

Thank you in advance.

PS. my near/far clip distances for the camera are 5 / 0


03-02-2010 03:37:26

Try adding a call to setCloudCover():

Caelum::FlatCloudLayer *layer = mCaelumSystem->getCloudSystem()->createLayerAtHeight(5000);
layer->setCloudSpeed(Ogre::Vector2(0.000025, 0.000045));



03-02-2010 09:28:53

Thank you for the answer.

I added the lines you have said, there are still no visible clouds!

I don't understand what i am doing wrong.


04-02-2010 00:09:52

Are there any warnings or errors in your Ogre.log? Also, are you able to successfully build and run the demo application that comes with Caelum?



04-02-2010 09:43:00

You are right. I do indeed get this error message in Ogre.log

17:00:56: OGRE EXCEPTION(7:InternalErrorException): Cannot load GL vertex program CaelumLayeredCloudsFP. Line 4879:
Error, line 148: parameter binding limit exceeded (max = 24, used = 27).
in CaelumLayeredCloudsFP at f:\codingextra\ogre\shoggoth_vc8\ogre\rendersystems\gl\src\ogreglgpuprogram.cpp (line 235)
17:00:56: Gpu program CaelumLayeredCloudsFP encountered an error during loading and is thus not supported.

It seems my video card does not support Caelum Clouds (i am programming on a rather old laptop, i will try on my desktop at home to see if it is alright)

I can compile and run the demos just fine, but i also cannot see the clouds there, same problem obviously.

Thank you for your help, you have been most helpful


05-02-2010 02:05:50

You're welcome :)