parsing *.os scripts?


11-02-2009 23:22:28

I feel really stupid asking this question, but how do I get caelum to parse *.os scripts? I have tried this and can't find any other usable "load" or "parse" sounding functions. 'skysetup.os' is in a path specified in resources.cfg. This code gets a "SandStormTest not found" sort of message:
CaelumPlugin::getSingleton().getPropScriptResourceManager()->load("skysetup.os", ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME);
CaelumPlugin::getSingleton ().loadCaelumSystemFromScript (mCaelumSystem, "SandStormTest");


12-02-2009 10:54:09

The .os script should be available through standard Ogre resource management; there's nothing special about that. Calling "loadCaelumSystemFromScript" should be enough.

Can you check that CaelumPlugin is installed before script parsing? CaelumSystem will automatically install it it's constructor; but CaelumSystem is created after resources have already been parsed. Trying addding Caelum in plugins.cfg or calling CaelumPlugin::install() manually at some early time.

Also; you might be running into trouble with resource groups; try explicitly mentioning the group name.


12-02-2009 17:54:26

Ah ok, I added caelum to plugins.cfg and problem is solved. Good work with the new version of caelum by the way!