File not found exception


28-10-2009 19:37:55


I have a really annoying problem with Mogre -.-

I set up everything like said in Tutorial 0, but nothings works.
I cant even run the Mogre samples because I always get the Error:
System.IO.FileNotFoundException: Das angegebene Modul wurde nicht gefunden. (Ausnahme von HRESULT: 0x8007007E)

And thats it. Program ends without any further information.

Hope you can help me



29-10-2009 00:09:48

Please, first of all - use search. There is plenty of such problems described on the forums. I.e. look here


29-10-2009 17:59:46

I should explained clearer that I nearly tried everything.

- Set PATH variable
- Installed DX as written in tutorial
- same with vcredist
- Downloaded Mogre SDK
- Edited the conf files (yes, both in debug and release)
- tried the Project template from Tutorial 0
- used different IDEs
- searched forum and google but nothing solved my problem

Maybe i should say that i use Win7 64bit (ans yes i tried the 64bit tips too)

The programs dont start, i dont get any message and no file is created.



29-10-2009 19:45:11


check that you've got all the required dll in the folder of your executable (in bin/debug or bin/release of your project)

you should have mogre.dll and ogremain.dll in the same folder. (i have the feeling that the tutorial is misleading on that)


29-10-2009 20:26:41


I also checked that and copied all dll's from the SDK Debug and Release to my Debug and Release
but it still wont work.


29-10-2009 20:33:20

Try to copy only the dlls from the SDK's release folder to both your debug and release folder.


31-10-2009 16:28:27

no, works neither -_-

Maybe its a problem with the conf files
Can someone post his files so i can compare?


01-11-2009 11:36:10

are you using the newest release of mogre?
I've had similar problems,
but if i right-click my project, then "build", and then executed .exe the like starting a normal .exe it worked, but did not work if I ran it from IDE.
(fine not found exception).. Tried everything, but gave up, went back to the 148 rel..


02-11-2009 15:30:26

If you use the release libraries, your plugins.cfg should look like this:
# Define plugin folder

# Define plugins

Do you have cg.dll which is required for Plugin_CgProgramManager?


02-11-2009 15:32:32

Looks exactly like this. and has the cg.dll file there.


02-11-2009 15:49:33

Try to catch the FileNotFoundException. It should show the name of file it can't find in the 'FileName' property.


03-11-2009 11:55:12


I had this problem and to solve it I copied all dll files from C:\MogreSDK\bin\Release tpo the same folder where is my .exe

Good luck!


19-11-2009 16:59:18


Which SDK version did you use?
Is there a warnign or exception in the file OgreLog.txt?

For the 1.6.x SDK the depencies of the tutorial 0 are OUTDATED. Also for the 1.4.8 SDK this could be.
Look for newer ones. (sorry for less details, I'm not shure about the needed version numbers)

You need to install the DirectX Redistibutable package. (not only the common DirectX)

File load exception also happens when OgreMain.dll is missing in the binary paths (yourProject/bin/debug and yourProject/bin/release).
Or if OgreMain.dll and Mogre.dll are different versions.

To copy all dll file to the binary path is a good idea. I always do that.
Also in Visual Studio I always change a property of the linked Mogre.dll file.
VS -> project map explorer -> links -> Mogre -> right click -> properties -> local copy = FALSE
In the past I had the problem, that on every run, VS replaced the linked dll file by an other (older) version. Since I do this change, this problems were gone.

I hope my ideas did help. If yes, please report what was the problem.

By the way:
Please change the thread topic to: File not found exception (installing Mogre SDK)
Then it's better for other people when they search for the same problem.