Problems with Basic Tutorial0


29-10-2009 01:56:15

I'm having troubles with the Mogre Basic Tutorial0 at this site:

When I start debugging, I get an error window titled "Microsoft Visual C++ Runtime Library" that says:

Assertion failed!

Program: ...
File: d:\cubicalminds\mogreworld\mogre\ogr...\ogreroot.cpp
Line: 100

Expression: ms_Singleton

For information on how your program can cause an assertion failure, see the Visual C++ documentation on asserts

(Press Retry to debug the application - JIT must be enabled)

I saw the following text on the tutorial page:

NOTE: If you get a line 80 or a line 100 exception after build, try to copy your build exe into the appropiate Debug or Release folder in your MogreSDK library (default: C:\MogreSDK\bin\(Debug or Release) and run it.

So I tried it out. It worked. Is there any way to get my programs to run without copying them to the C:\MogreSDK\bin\Debug directory every time?

thank you for your time,


29-10-2009 11:15:34

To run your application you need to have certain dll files in your application exe directory. I.e. Mogre.dll and OgreMain.dll. You can look here to find out needed files:

If you use Visual Studio you can change project settings to build exe file right into MogreSDK/bin/Release (or Debug) directory where all needed files already is. Or copy em manualy into your app directory as i said above.


29-10-2009 21:42:42

It works now!

Thank you!