FileNotFoundException of Mogre 1.7(1.4 is Ok)


10-08-2010 02:06:16

Hey guys ,the last time I post a tread about the Clr using ogre exception problem.And I solved it by using Mogre Sdk v1.4.6 and it works well.But unfortunatlly when I try to use v1.71 and other versions the winform always throw a FileNotFoundException .I had set the libs dir and include dir and copied the libs and dlls (OgreMain_d,RenderSystem_Direct3D9_d,RenderSystem_GL_d) to the debug folder(both in the clr and winform solution debug dir).But it still throw the exception!
Anyway could tell me what's the difference between two version that would cause this trouble and what file had I missed?


11-08-2010 01:33:41

The depencies of Mogre 1.7.1 needs a newer version than the 1.4.x ones.
Did you install the MogreSDK in version 1.7.1?
By installing the SDK your system will be checked for the depencies and update them if needed.
Maybe this solves your problem.


30-08-2010 21:14:41

I guess ownsun's problem is the same or at least similar to mine. I'm using MogreSDK 1.7.1 with Visual Studio 2008. I did everything in Tutorial 0 (that is, I'm sure I referenced the right dlls and did the correct setup) and tested with BasicMogreSetup template too, both changing the relative path in *.cfg to direct path and even copied the /Media folder to the project folder. I still got the following message, for either of the methods I tried.

An unhandled exception of type 'System.IO.FileNotFoundException' occurred in mscorlib.dll

Additional information: The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Any insights? I haven't tested with other versions of the SDK yet.


05-09-2010 23:39:09

The basic tutorial 0 isn't needed anymore. (All needed things will be done by the SDK installer.)

Can you try the demos of the installed Mogre SDK, please?
After compiling the demos the created exe files are in directory MogreSDK\bin\Release.
Maybe they were still compiled by the SDK installation process (can be done optionally after the depency check).
If not, call BuildSamples.cmd.

Please let us know, if the demos are working.