Problem with getting the MogreNewt Sample Solution to run


14-12-2010 22:43:20

Hello everyone!

I hope I am not the only one with that problem, because then I would look really dumb in the next couple of seconds ;)

I really like MOGRE, it is my third engine I work with and I really enjoy the structure and the Tutorials.
But I had a hard time getting the samples to run, it took me almost two hours.

Now I'm starting to try Newton and had the same problem. Here's a summary what happened so you can understand why I am a little frustrated:
I downloaded the MogreNewt for Newton 1.53 at ... eNewt-1.53 and of course the Newton Framework.
I opened the VS09 Solution for the samples and just wanted to have a quick look how it feels. But the build failed.
What I've done so far:
- Set all the references for Mogre, MogreNewt, MOIS by hand
- Find the Mogre.Demo.ExampleApplication.dll and reference it
- copy all the missing .h files from Ogre / Newton in MogreNewt_Main\inc\ (a lot of files...)
- Clear the build events that threw errors
- Create new directories and copy the Mogre.dll to "..\..\Mogre\ogrenew\lib"
- Set the "Resolve #using References" to my Mogre.dll folder because i got an error that he can't find the dll
- After researching via google about the "fatal error LNK1104: cannot open file 'libcp.lib'" set it to ignore this lib and LIBC.lib
- Finally i had a "error PRJ0019: A tool returned an error code from "Performing Post-Build Event..." error

After that I'm stuck with an error and my C# Projects doesn't like the using Mogre; anymore, despite of having the correct Reference.

So after two hours of trying to get the samples to work I just have to ask:
Am I too dumb, did I do something really, really wrong or is it just so damn hard to get the Solution to compile?
Sorry if I'm completely wrong but: Couldn't someone please upload a zip or set a tag in the svn for newbies like me with a completely working Samples Solution withouth having to puzzle all the pieces together?


15-12-2010 11:52:31

Hi SirDregan,

welcome to hour Mogre world - nice to see that you like it :D
The tutorials were been updated (after a long time) by one of our good boys. Also he created a fresh TutorialFramework to simplify the Mogre start of newcomers.

For my main project I also use Newton.
Unfortunately the MogreNewt wiki page is very outdated.
Don't use Newton 1.x. Use Newton 2.x instead. It still contains the beta label (for about 2 years now), but it's quite stable.
You can grab a precompiled library from the forum thread Mogrenewt 2.0 [Binary on first post].
That thread is also the main support thread for MogreNewt where you can find useful information.

Sometimes ago I wrote how to find further information and help:

When you need information how to do something with Newton or if you have problems by using Newton I would suggest this:

* For general questions (how Newton works, its logic, etc.) you find good help in the external Newton forum.

* For questions how to do something in interaction with Ogre (and Mogre), you can use the OgreNewt section of the Ogre Add-ons forum. There is a better chance to get an answer, because there are much more users who know to handle with Newton. Here in the Mogre section are not so much people with Newton knowledge (because C++ Ogre is more common).

* For Mogre and MogreNewt specific questions the Mogre section of this forum is a good place. Just create a new topic (your topic title should include the word MogreNewt).

A good help could also be:

* Newton wiki
* Newton API description - seems to be only related to Newton 1.x, but most functions are similar

Related to collision detection with MogreNewt I published a demo application. Look here:

There is also an alternative physics library which you can use with the current Mogre version:
[b]PhysX Candy Wrapper[/b].
I read it works well, but related to Ogre/Mogre there seems to be no or less information about the usage.
But for general information there should be much stuff available in the internet, because it's common used (as I suppose).

In this thread you can find a precompiled version of the PhysX wrapper related to Mogre. But remember that the binary bundle of that thread contains modified libraries, which could cause a conflict with "common" Mogre related libraries.

I hope I could help.


15-12-2010 11:57:35

For use with MogreNewt:
Download the file MogreNewt.xml from here and add it into you binary directories: ... reNewt.xml

Then you will see XML descriptions of the MogreNewt class members.

If you don't have the XML file for Mogre class descriptions, download the file Mogre.xml, too. ... /Mogre.xml

The file was created by the Mogre XML commentation tool.


15-12-2010 13:54:58

Thanks alot for the quick and big reply! :)
I'll check out your links in the next couple of days.


15-12-2010 20:08:09

*sigh* So I had even more problems with the MogreNewt 2.0 Solution.
I couldn't open any of the two solutions or any projects, i always got a error while opening.

Your samples did work, but guess what? Just the .exe works.
If i try to compile your solution it throws errors (in the Collision by contact callback he can't seem to find the "ContactCallback" class you inherit from and in the "by Iterator" he doesn't know ContactMaterial and body.ContactJoints)
I'll try to bite my way through that on the weekend, just wanted to let you know what happened.


15-12-2010 22:06:14

I tried it and got the same error now. Strange. Before publishing it did compile.
Now I have a new Windows system and a newer version of Visual Studio. If this could be really a reason I don't know.

In the last minutes I tried to include newer libraries (they were very outdated), but this needs some changes, because of different API details.
Maybe I can check this more deeply this week.
Additionally I think about to re-create the examples, using the TutorialFramework and the current MogreNewt version.


28-12-2010 14:33:43

I'll give up. I tried every sample, tried building a sample solution from scratch - nothing.
The best I can do is end up with a "Module not found" error withouth being able to locate the source. No InnerException, nothing in the process manager seems to tell me what he's searching for. I'll try another physics engine now.

Anyway, thanks for your replies and I wish you a happy new year.