Mogre & x64 operating system


13-06-2011 13:11:44


I'm trying to run Mogre 1.7.1 under Windows Seven 64 bits, Visual Studio 2010 32 bits and with the 4.0 .NET framework. Unsuccessfully.

I searched "all around the web" and didn't find precise answers to my questions. I am unable to find a correct configuration allowing me to run it without problems. First I tried to run it under WOW64 by specifying the target to "x86". It worked for the Mogre.TutorialFramework but when I try to start a brand new project (as the tutorial 5 explains) execution errors were back. Then I thought in building the Mogre framework for a x64 target from scratch. But I didn't find anybody explaining he already successed in building it. I tried it but I was unable to make it build until the end.

So my questions are :
- Does anybody is able to run the tutorial 5 from an empty project on x64 operating system (if it is which is you're project configuration : libraries, references...) ?
- Does anybody successed in building x64 version mogre libraries ?
- Which libraries are essential to run Mogre ? I saw different libraries references in different projects and I'm a little confused on which ones to use in a brand new project.

I'd like to avoid a system reinstallation to a 32 bits operating system just to run Mogre... :D

Does anybody can help me on this ?

Thanks !


13-06-2011 14:13:43

For me it worked when I Set the target to "x86" Not "x64" and not "Any CPU" ...
Hope this helps :)


13-06-2011 23:48:32

First, thanks for answering me !

Can you explain me exactly which libraries you're using (references...) and which is the configuration of your project ?

Thanks !


17-06-2011 10:31:43

I figured out my problem.

For those who are interested in here is what I realized to have an empty project working on my x64 OS machine. I created a project on a x86 OS machine with Mogre compiled for the .NET Framework 4.0 that I found on the web. I created all the references needed to link Mogre to my project then I configured all the configuration files. I made the project not dependent to the machine that compile the project by embarking the Mogre ressources needed with the project sources. Once the project worked on that machine I transferred it to my x64 OS machine. I compiled it for x86 target and it worked perfectly.

I'm unable to find what was wrong whith the first version of my project but I think that was from my project configuration (references, ressources...).

I hope it can help !