Initializing Mogre - System.IO.FIleNotFoundException


04-07-2011 15:34:49

It's a rookie error, I'm sure. I've installed the latest MogreSDK (1.7.1) and I'm trying to create a Mogre form, and following the MogreForm sample provided to start it off. When I run my project in Debug I get an error message saying :
An unhandled exception of type 'System.IO.FileNotFoundException' occurred in EfritEd.exe
Additional information: The specified module could not be found. (Exception from HRESULT: 0x8007007E)

And if I run it in Release:
This application has requested the Runtime to terminate it in an unusual way.

The actual line that this breaks on is:

I'm running VS2008 on a XP 32bit machine, and the only answer I can find on the forums is set the compiler to x86. I've done that. I've also used the BuildSamplesX86.cmd to build it properly (after running CleanSamples of course). I copied all the .dlls over to my build directory and added in my .cfg files (setting their proper path as well). I've tried just copying the sample but that didn't work either! If I run the actual sample itself, Release runs fine, but Debug won't run at all (literally, nothing happens). If I compile it from source Release runs fine, but debug gives me the error:
Error while trying to run project: Cannot start debugging. The assembly to be debugged was built with a platform incompatible with the current system.

Is there something that I haven't setup properly? I've no idea whats going on here...

Thanks in advance


17-07-2011 02:34:04

Hi Monfortae,

I'm sorry that you have so much trouble with your first Mogre experience. Also sorry for my late reply.
Your problem report is detailed. And I see you still searched in the forums. Thanks.
Unfortunately I don't have an idea what causes your trouble.

I never read a file name called EfritEd.exe. Also Google doesn't know this file.
The current SDK should work fine in general, even on WinXP 32bit. (I used it with VS2008 on WinXP for a whicle, too.)
Are you shure, you also installed the depencies, which are offered in the setup process?
Did you update the driver of the graphic card?

The actual line that this breaks on is:

I don't know mogreWin.InitMogre(). Where did you find the code with this call?

Did you try to process and run the Mogre Basic Tutorial 1?
It would be interesting if this works fine or also causes problems.
Can you try it out, please?

What's your .NET setting?
The dll files of the SDK are related to .NET 2.0 up to 3.5. They are not usable with .NET 4.0.
(With .NET 4.0 you need dll biles build for that target. Such dll files are offered somewhere in our forum.)

With the debug version I have no experience. I always just used the release version for my project.
I just know that it's not good to mix dll files which were build for debug with others build for release.

More ideas I can't tell you at the moment.