problem with new version 1.9 MOGRE. [SOLVED]


24-01-2007 05:20:02

well even with the helpful post of ernesto i couldn't get the new version to work, it keeps throwing the same error:

System.IO.FileLoadException was unhandled
Message="Could not load file or assembly 'Mogre, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. No se pudo iniciar la aplicación porque su configuración es incorrecta. Reinstalar la aplicación puede solucionar el problema. (Exception from HRESULT: 0x800736B1)"
FileName="Mogre, Version=, Culture=neutral, PublicKeyToken=null"
at MOGRELV_v1.Program.Main()
at System.AppDomain.nExecuteAssembly(Assembly assembly, String[] args)
at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()

i even tried without luck to create a new project from scracth....


24-01-2007 09:03:11

I think it's because it requires the SP1 VC libraries.
Get the SP1 vcredist_x86, install it and let me know if it fixes the problem.


24-01-2007 16:13:57

even if i'm using visual studio 2005 on a windows XP professional with SP2?.. anyway i 'll download it and i'll tell you.


24-01-2007 16:46:42

ok i have been reading about the file you sent me there is also a SP1 for the visual studio but also i found this posts in msdn forum:

the link for the 430MB SP1 for VS Studio is:

in the posts were talking about some difficulties about deploying apps that were done witht he SP1 of VC++.

hope this helps, i'll let you know what happens after installing the SP1


24-01-2007 17:50:42

Is this really the problem? Does the latest Mogre require VC SP1? As, I don't really feel like downloading that SP so I hope it is not the case :/


24-01-2007 18:15:28

I think installing the SP1 vcredist_x86 file which is only 2.55 MB is sufficient and installing the whole VS SP1 is not necessary.


24-01-2007 18:48:36

I installed Visual Studio SP1 some days before Mogre 0.1.9 I don´t have any problem with Mogre. Well maybe this is the problem with people getting exceptions.


24-01-2007 19:08:59

I installed the MS Visual C# Express SP1 ... 6-INTL.exe

This solved the problem.

Thank you very much for figuring it out.



24-01-2007 21:53:23

YEAH the 2.5MB install doe the job now it works now it reserves the [solved] label i will put it now, only i have the shadows issue, that doesn't seems to be resolved witht he new MOGRE version... so anyone interested in the problem can read the post named "shadows makes Mogre to CRASH" i need help on that.. ..pls?


24-01-2007 22:01:21

I think installing the SP1 vcredist_x86 file which is only 2.55 MB is sufficient and installing the whole VS SP1 is not necessary.

Ah, that sounds more reasonable. I have just heard of several problems with the SP1... but, I may end up getting it anyway.


26-01-2007 19:45:38

The small one didn´t solve the problem for me, but the big one did.
However, I get another problem when trying to run Tutorial 0 now. When I press debug, the application starts and you can see the Mogre window, but when it has loaded about 30% I get a runtime error:

Runtime Error!

Program ...Studio 2005\Projects\Mogre\Tutorial\Tutorial\bin\Debug\Tutorial.vshost.exe

This application har requested the Runtime to termintare it in an unusual way. Please ocntact the application's support for more information.

Anyone knows how to solve it?


27-01-2007 00:07:07

I also get that error, but I don't get it "occasionally.", I either get it, or I don't.

The last time I got it, I was trying to add terrain.cfg prior to setting up the cam.



27-01-2007 14:26:03

ruler81 and CK_MACK, this is probably caused by an Ogre exception; read this