The procedure go() cannot be loaded...


25-05-2007 13:50:00

I really want to make my game in MOGRE but i can 't make the 1st tutorial

static void Main()
OgreWindow win = new OgreWindow();
win.Go(); <---- error is here :

La procédure spécifiée est introuvable.
The specified procedure cannot be found

I'm certain to have follow the instruction of the installation of MOGRE.

Or maybe it's an error due to the SP1? I'm using both vc++2005 and vc# express. I have installed the SP1 but it seemed only to update VC++ 2005, i don't know if it works for both IDE.

Thanks for the help


26-05-2007 13:49:06

Could you post more code, including your "using" section, and can you run the sample applications?


26-05-2007 23:40:46

So i desinstalled ogre, reinstalled ogre 1.4.0 + mogre, downloaded the sp1 for visual express, it was already installed. I reinstalled ogre 1.4.0 + mogre and unrar mogreframework and i tried to start the samples by changing the start project (i ve not understand what is "build batch all the samples" and how to do that. I dont have "start external program" in properties/debug and i don't know what is it for, i completed working directory and when i compiled the compiler throw me an error saying
OGRE EXEPTION (6:FileNotFoundExeption):'resources.cfg' file not found! in ConfigFile::load at ..\src\OgreConfigFile.cpp(line 84).
(than i saw all the mogre-samples exe and when i tried to run them, it worked)
I tried to add the 4 cfg to the start project and i changed the properties to copy them, but without success)

Si i re-open my own solution, check the references : mogre and mogreframework were loaded. I have only program.cs and all the 4 .cfg from the SDK directory and VC# copied them at compilation(in properties). When i start the project, i have an error saying :
Runtime Error:
program : blabla/TestMogre1.vchost.exe
This application has requested the runtime to terminate it in an unusual way. Please contact...blabla... :(

my "full" (lol) code is :

using System;
using System.Collections.Generic;
using System.Windows.Forms;

using Mogre;
using MogreFramework;

namespace TestMogre1
static class Program
static void Main()
OgreWindow win = new OgreWindow();


27-05-2007 07:19:53

I think you have to initialize mogre first. You have to see the code in the demos. Some uses the ExampleFramework that initialize mogre.


27-05-2007 11:39:33

oops: Roger: i checked the file media.cfg, correct the paths and add media/packs/ and it is working now, sorry to bother for nothing