Could not load dynamic library .\RenderSystem_Direct3D9_d.dl


25-03-2008 01:54:36

Hi everybody,

I´m just getting started with MOGRE and I have the error below when running my first program T_T

14:04:14: Loading library .\RenderSystem_Direct3D9_d.dll
14:04:14: OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library .\RenderSystem_Direct3D9_d.dll. System Error: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

in DynLib::load at ..\src\OgreDynLib.cpp (line 80)

If someone can help me, please ^^



29-03-2008 15:16:24

Did you remember to install the Direct X Source Developer Kit ? ... ctX10.aspx

even though it's Direct X 10 and not 9, it should be backwards compatible.


30-03-2008 11:26:15

It's not DX SDK related. You should find explanation here: ... hp?p=23659


01-04-2008 16:50:05

Thanks ^^
I installed in another computer and the everything works fine.
I guess I forgot to install something. ^^"


14-05-2008 08:57:57

64 bit X2 CPU ?


22-06-2008 17:41:23

Are you using Ogre SDK 1.4.8? You should!! Read this: ... 245#291245


23-06-2008 14:57:02

Take a look into Windows' System Management Console (MMC). Browse to Event Viewer / Application and see if there are any "Side-by-Side"-errors. Usually they tell you why it couldn't load a dll.


20-01-2010 21:59:54

I had the same problem and it turned out to be that the plugins.cfg was configured wrong. I copied the config files out of the Debug folder and all the plugins had a _d suffix.


you have to link to the release version though, so you have to take off the _d and after that it works like a charm.

# Define plugin folder

# Define plugins


26-04-2011 18:27:57

On this same topic, how exactly does the _d get appended to these file names? Is there any way to strip the _d away through a build? I have a project that is insisting on looking for OgreMain_d.dll but I build it as OgreMain.dll. Where can I strip away the appending _d? Thanks for any help!


29-01-2013 18:44:47

When you build it in debug mode, the _d gets appended. Try changing it to release and it should go away.


30-01-2013 19:29:17

Yes, "_d" means it's a library, which was compiled with enabled debug options.
But just renaming it is a bad solution, because a mix of debug and release builds can cause trouble.

The best is to use a binary bundle, which was compiled together. (Either as release or as debug version)
For common usage the release libraries should be fine.

Mogre can be compiled very easy by help of the MogreBuilder.
By default it creates release binaries.
For debug binaries just use a modified config file, where you change the target from "release" to "debug".

Alternatively you can download debug and release binary bundles from the forum topic Mogre 1.7.4 binary files (release + debug) + MogreNewt 2.35.