[solved] MogreNewt with 1.6.2


27-04-2009 08:56:22

has anyone compiled a mogrenewt that works with mogre 1.6.2?
i tried to myself, but ran into some troubles.

first i used the include files from my own regular ogre release, but i think it might be 1.6.1 which i suppose could cause a problem.
anyway, i added it as a reference and added some code and then got a TypeInitializationException when trying to run my program.

then i tried using the include files that come with the mogre 1.6.2 testing release, but it wouldn't compile, lots of nedallocpolicy and clrobject unresolved externals.

maybe mogrenewt 2.0 works with 1.6.2? i suppose i'll have to try it..


27-04-2009 09:47:03

I managed to compile it. I just pointed it at the 1.6.2 header files and libraries, I had to remove some include directives as well.


27-04-2009 14:06:01

duh - i'd pointed it at the new include files, but forgot the new libs. now it compiles. thanks.


28-04-2009 18:13:33

Would you mind posting already compiled MogreNewt for some lazy people like me ?


29-04-2009 15:22:50

could you share with us?

please please


02-05-2009 18:28:44

There are some little API differences between Ogre 1.4 and 1.6.
Mogre 1.6 is still only a beta version.
Maybe some users want to use Newton 2 with Mogre 1.4.

So how we want to handle it in the MogreNewt SVN?
Make it compatible to 1.4 or 1.6?
Or split into 2 branches, what would be not so nice for updates.

I think for answers it's better to post it in the main thread of MogreNewt 2.
There I inserted a quoted copy of this post.